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Error "Can't Open Quickbooks. Quickbooks already has a company file open." When Trying to Send to Accounting Using Quickbooks

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TitleError "Can't Open Quickbooks. Quickbooks already has a company file open." When Trying to Send to Accounting Using Quickbooks
Summary
Symptoms
  • Error "QuickBooks already has a company file open. If you want to open another company file, close this one first."
  • When attempting to transfer anything to Quickbooks, RepairCenter is crashing with an Unexpected Error. 
  • Testing the connection to Quickbooks in RepairCenter isn't successful but doesn't produce any errors. 
  • The following error is listed in the RepairCenter error log:
<Message>Exception Information Details: ====================================== Exception Type: Mitchell.Repair.ActiveX.Interop.Exceptions.ActiveXException Message: (0); clsAccountsQBXML.sptXMLBuild HResult: -2146233088 </Message>
 
EnvironmentQuickbooks
Cause
  • The company file path location is incorrect
  • The required MS XML 4.0 is not installed or outdated XML 4.0 service pack
  • The network drive is mapped as admin and the applications are not running as admin so they cannot access the network drive.
Resolution
Solution 1
Verify QuickBooks company file being used matches in both QuickBooks and RepairCenter.

In QuickBooks:
  1. Press F2 to pull up the Product Information window 
  2. Note the current path and name of the company file
  3. Close QuickBooks
In RepairCenter:
  1. Click on More and select Configuration
  2. Select Accounting tab, then select QuickBooks tab
  3. Click Browse to locate the path found in QuickBooks for the current company file
  4. Click Update
  5. Open QuickBooks
  6. In RepairCenter click on Test Connection - (If the test is successful you should be able to post to QuickBooks.)
Solution 2
If problem persists follow these steps to install MS XML 4.0 SP3.
  1. Close QuickBooks and RepairCenter
  2. Download XML 4.0 SP3 here. (select msxml.msi)
  3. Run the downloaded executable
  4. Once complete you should be able to successfully test connection and post
Solution 3
When mapping a network drive as admin, it will use the Admin user profile. Applications not running as admin will not be able to properly access it.
  1. Right click on RepairCenter and select Run as administrator.
  2. Right click on QuickBooks and select Run as administrator.
  3. You may now test connections to generate the ARMS file in QB (make sure QB is set to single user mode and logged into QB as admin for this part).
    1. If the ARMS file already exists you may ignore step 3 and continue to step 4.
  4. With QuickBooks now running as administrator and in multi user mode (if this is a multi user setup), you should successfully be able transfer to QuickBooks.
Additional NotesXML 4.0 download: https://www.microsoft.com/en-us/download/details.aspx?id=15697
URL NameError-Can-t-Open-Quickbooks-Quickbooks-already-has-a-company-file-open-When-Trying-to-Send-to-Accounting-Using-Quickbooks
Validation StatusValidated

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