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"Unable to contact Mitchell to determine if this vehicle has any active recalls. Verify your internet connection is working and try again" When Opening Estimate

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Title"Unable to contact Mitchell to determine if this vehicle has any active recalls. Verify your internet connection is working and try again" When Opening Estimate
Summary
Symptoms

The user receives the above error when attempting to open an estimate.

EnvironmentUltraMate
Cause
  • Slow Internet connection.
  • The MitchellCertificateStore.store is expired.
  • The user’s WorkCenter account is locked.
  • UltraMate requires repair.
  • Mitchell Communication Manager requires running as administrator.
Resolution

Solution 1: Verify there is a good Internet connection. This can be accomplished by performing a speed test at services such as speedtest.net.

Solution 2: Rename the file Mitchell Certificate Store.  Note: This solution only applies to insurance staff users.

  1. Navigate to C:\ProgramData\Mitchell.
  2. Rename the MitchellCertificateStore.store file.
  3. Launch UltraMate and log in with an administrative user.
  4. Click System Info, select Configuration, then click Configure User Information. 
  5. Double-click the user's User ID.
  6. Click Test Communications. This will generate a new MitchellCertificateStore.store file.  Click OK and close the User Manager.
  7. From the File menu, click Logoff. Once the login window opens, log in with the user's normal credentials.
  8. Open the estimate to verify normal operation.
Solution 3: Account is locked. Note: This solution does not apply to Progressive staff. 
  1. In a browser, navigate to www.mymitchell.com (US) or wwwca.mymitchell.com (Canada).
  2. Input the user's credentials. If the user receives the notification "Account is locked", proceed with the steps.
  3. Click Need Help Signing In?
  4. Enter Organization ID and User ID then click Send Instructions.
  5. Follow instructions in the user's email to change the password, which will unlock the account.
  6. Open the estimate to verify normal operation.
Solution 4: Repair UltraMate.
  1. Refer to: How to Run a Repair on Mitchell Estimating.
  2. Open the estimate to verify normal operation.
Solution 5: Set Mitchell Communications Manager to run as administrator.
  1. Navigate to C:\Program Files (x86)\Mitchell\Support\Communications (64 bit) or C:\Program Files\Mitchell\Support\Communications (32 bit).
  2. Right-click the McDm.exe file and click Properties.
  3. On the Compatability tab, enable Run this program as an administrator.
  4. Click OK.
  5. If the UltraMate install is single user, skip to step XX. Otherwise, click Start and search CMD.
  6. Transfer and run the attached EnableLinkedConnections.reg file, clicking Yes on any security prompts.
  7. Reboot the computer, then test opening an estimate to verify normal operation.
Additional Notes
URL NameUnable-to-contact-Mitchell-to-determine-if-this-vehicle-has-any-active-recalls-Verify-your-internet-connection-is-working-and-try-again-then-UM-stops-responding-again-When-opening-all-estimates
Validation StatusWork in Progress

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